All systems are back to normal operation. Our infrastructure is currently working through a backlog of queued documents that accumulated during the incident. As a result, you may experience delays in document processing over the next hour.
No action is required on your end. Documents will be processed automatically.
Posted May 06, 2026 - 14:43 UTC
Monitoring
The fix has been deployed and document analysis should be functioning normally again. We are closely monitoring the situation to ensure full stability.
Posted May 06, 2026 - 14:09 UTC
Identified
We have identified the root cause of the issue: an unresponsive cloud resource that is part of our document processing infrastructure. We are currently rerouting traffic to an alternative GDPR-compliant resource and expect the fix to be fully deployed within the next 15 minutes.
We will confirm once normal service has been restored.
Posted May 06, 2026 - 13:58 UTC
Investigating
We are currently experiencing an issue that prevents documents and PDF files from being processed in the MAIA App via our Advanced Document Analysis pipeline. We're investigating the issue.
All other features of the MAIA App remain fully operational. We can confirm that there are no security implications.
We will keep you updated here and are working to restore full functionality as quickly as possible.